PDA

View Full Version : Languege/sound probelms



Keeper_Infernal
June 28th, 2010, 13:38
I download DK2 1.3 version and i am very pleast from the AI and the game in general (even throgh i cent edit level or create new once..)
but i have a littel problem wite the game, the game is in german. i have noticed that in the data folder there is a folder named english and i also read i file named english.txt wich inside him it seys: play this game in englisch, import dk2eng.reg and
change the directory in DATA\TEXT !!!

waht the hell does it mean?? :confused:

and anoter thing the evil voice the one that tells me about things heppening in the dungeon (it just cent stay like that! it has to have a name!! how about: "the voice of evil"? :D)

does not exist i cheked in the sound option and i order him to talk and i even pressed on that moving button on the bar and he start to count in english from 1 to 10 yet he does not speecks. :(

and the backround music wich is so needed to create an evil gameplay doesent exist! :mad:

if cen anybody bring back the dark symphony of DK2 is you Keepers!!:D pleas help me! :o

DragonsLover
June 28th, 2010, 19:31
What does english folder contain? If there's a "Default" folder and a "JCN.dat" file, then simply rename "English" by "Text" and replace the old "Text" folder by that new one.

As for the .REG file, it surely removes the censorship. You can modify that yourself:

1. Click on "Start" then "Run" (or if it is not there, click on "All programs" >>> "Accessories" and it should be somewhere around there).
2. In the bar, type in: regedit then click OK.
3. Go there: HKEY_CURRENT_USER >>> Software >>> Bullfrog Productions Ltd >>> Dungeon Keeper II >>> Configuration >>> Player
4. Set "Blood" to 1 by double-clicking on it and changing the value.
5. Go in "Video" and set "Torture Details" to 1 by double-clicking on it and changing the value.
6. Go there: HKEY_LOCAL_MACHINE >>> Software >>> Bullfrog Productions Ltd >>> Dungeon Keeper II
7. Set "Language" to 0 by double-clicking on it and changing the value. If your main language is not English, change that value to something else until you get the good language. To know which language you picked up, run the game and look at the title screen.

That should be fine!

Keeper_Infernal
July 1st, 2010, 19:30
I have a text folder wich inside it i have a folder called default and another folder named default_english and the file you mentioned, i dont have it. waht shell i do in this case?

and i changed the value to 0 i tryed the reg file and wen i was going back to see the value it was 9 agein -_- waht to do? :(

DragonsLover
July 3rd, 2010, 04:23
Oh, so you have a folder named "default_english"? Just rename that folder to "Default" (without quotation marks) and place that folder in the "Data\Text" folder where the game is installed, replacing the folder of the same name.

Why did you try the REG file? Just don't use it and bring the modifications manually as I explained.

Keeper_Infernal
July 4th, 2010, 05:43
Ok ll try it out


Edit: changing ther folders name have changed the game back to english Thx man! yet are still a
3 more problems:

-No speeches

-No backround music (what benefits has the spell sumun horrny witout it? )

-wen on wide screen mode text is not showing (through outside wide screen mode text is showing)


Any idies??

DragonsLover
July 6th, 2010, 03:00
Perhaps next time, you should use a REAL copy of DK2 and not a downloaded version taken from Germany to avoid those problems? :rolleyes:

Okay, did you get speeches and music before altering the texts? If not, if you still don't get speeches and music, then it's a problem with the "Sound\sfx" folder which contain the sound effects, background music and mentor speeches. Is that folder alright? Do you have lots of "speech_***" folders in it? Next, check in the ingame options if everything is okay.

As for the "widescreen" mode, it shouldn't exist in DK2 as in that time, it was mainly 4x3 screens. Be sure that you set the resolution to 1024x768. To do so, go back in the Registry like I explained before and go in the "Video" folder. There, set "Res 1024*768 Enabled" to 1 and change "Screen Height" to 768 (300 in hexadecimal) and "Screen Width" to 1024 (400 in hexadecimal). You can set your screen resolution to use 16x9 resolution, but textures of the UI during the game may become stretched and ugly and thus, isn't recommended.

Keeper_Infernal
July 6th, 2010, 06:31
I have manegd to fix enything thx to you! :) :D only thing now left is the backround music...

DragonsLover
July 6th, 2010, 20:24
Background music is stored in "Sound\sfx\Global" folder inside files named: "Track_*_*HD.std" and "Track_ZeroHD.std". Do you have these files?

Also check in the ingame options if the music is activated and if the music volume is high enough.