PDA

View Full Version : 1.7 on gameranger now



NoOpen
May 27th, 2012, 13:49
GAME OVER! Do not see a delete button lol

MaxHayman
May 28th, 2012, 10:30
most people dont use 1.7 for multi

NoOpen
May 28th, 2012, 11:36
most people dont use 1.7 for multi

Understood but 1.51 and below take away to many aspects for my liking.