PDA

View Full Version : How I got Dungeon Keeper II 1.5 running



xXDzepniXx
September 24th, 2016, 22:08
Alright guys, I have had a huge pain trying to get DKII running on my Windows 10 ASUS Laptop. Although the information I have gathered from many sources and my own accounts, I hope this helps you as much as it did to me.

First off, I downloaded and installed DKII from GOG, it was automatically 1.7, and had the HW Fix thing. I immediatily went and got the GIM (General Improvement Mod) so I can play 1.5, I hate the 1.7 AI.

I downloaded GIM, extracted all the files from GIM zip to my DKII folder (where you will find DKII, DKII-dx, etc).

Everything went fine and I went into DKII.exe (this is the only way to play 1.5) I had no compatability set, the only thing I did was run the program as admininstrator. I go into the main menu, and I already notice black pixels, how do I overcome this?

I went out of the game, went into regedit, I went into HKEY_CURRENT_USER\SOFTWARE\Bullfrog Productions Ltd\Dungeon Keeper II\Configuration\Video. From here I went and edited the Engine ID from 2 to 4 (this works for some, but didn't for me), I also edited Screen Hardware 3D, although I played with it, so if it was 0, I would set it 2 or 4, and so on I would play around with it.

I went into the game through DKII.exe (only way to play 1.5) and still I notice black pixels, alright I go into graphics in the main menu and turn off Hardware Acceleration, by unchecking it. I then blindly go into a campaign mission and when I enter the mission the black pixels are gone.

ALTHOUGH, I notice that the shadows of the creatures are pixelated and not smooth, rather chunky and do not look like shadows at all. And I encountered many problems, for example I would crash if I press the Main Objectives, or sometimes when I try to save the game, pretty much anything I wanted to do was a trap. And when I exit the game and go into it again I have to turn off Hardware Acceleration for the pixels to go away, this was a constant task.

So I looked, what could I possibly do? I found a forum post where a fellow saw NVIDIA being an issue, do note that some people used these at the end of their shortcut, Target for DKII " -softwarefilter -32bitdisplay -32bittextures -enablebumpmapping -enablebumpluminance". I didn't use those before and after my fix. Instead I searched and saw what this guy did with the NVIDIA Control Panel, so I did the same.

First I went into the NVIDIA Control Panel, then on the left corner under 3D Settings I clicked Manage 3D Settings, then I saw Global Settings and Program Settings in the middle of the NVIDIA Control Panel, but I did not touch Global Settings. The fellow who posted about the NVIDIA fix said that Dungeon Keeper II does not like being told by NVIDIA what to do, and I see that he's right. First in the Program Settings tab, I selected my program to customize I clicked the DKII.exe in the installation folder, NOT MY SHORTCUT, the fellow said that he created a profile but I saw nothing of the sort. My first problem when I clicked DKII was that I noticed all my settings in #3 was gray, I could not click them. So I looked at #2 and clicked it, and I clicked whichever gave me most options to editing the game, which was High-Performance NVIDIA Processor. The fellow said that the only thing he changed was the Antialising - Mode in #3. I did the same, although keep in mind when I set the NVIDIA controls my DKII shortcut had these following at the end of Target, " -softwarefilter -32bitdisplay -32bittextures -enablebumpmapping -enablebumpluminance". I know I said I did not use them, but I was desperate and tried everything. Just keep it in mind nonetheless, moving on, I first tried Antialising - Mode set to Off, I went into the game and tada! I saw no black pixels, for the first time, I thought I was good, but when I went into a skirmish or campaign mission, my screen turned tiny and it wasn't even full screen, DKII was in the top left corner and I could see my desktop. I went out of the game and tried different settings, the fellow said Off, or Application Controlled, or Enhance the Application Setting. Although he said Override Any Application Setting is bad, and so I set it to all of the ones he said, but it didn't fix the issue. I eventually set it to Use Global Setting (application controlled). I went into the game, I still have the problem. I forgot to mention my game was horrible in frames in the main menu, this never happened before. So what I did in the end was I took off this " -softwarefilter -32bitdisplay -32bittextures -enablebumpmapping -enablebumpluminance" from my Target in my DKII shortcut. And voila! That fixed a big problem, I went into the game, no black pixels in the main menu and when I went into the game I found that the shadows actually look like shadows!

I will continue to update this as I find things out, I suffered numerous hours trying to figure out what the hell is going on with DKII, and I wish to compile my knowledge from many sources into one, and hopefully help all those in need, I greatly apologize to the people whom also gave their knowledge into several posts and I did not give credit, please not I did not figure ANY of this out, it was many people, I just don't know who they are.

So, all in all, I have a DKII shortcut, with no " -softwarefilter -32bitdisplay -32bittextures -enablebumpmapping -enablebumpluminance" at the end of the shotcuts Target, I used NVIDA Control Panel to set in Program Setings under Manage 3D settings, that Antialising - Mode is set to Use Global Settings (application controlled). I do not use compatibility (Windows XP Service Pack 2, etc) I only have the program run in Administrator Mode. Also I set my DKII folder (C:\GOG Games\Dungeon Keeper II) to highest permissions by right clicking on my Dungeon Keeper II folder, Properties, Security, Edit and gave ALL Group or User names a check mark (full permission). Those who wish to experiment with the Global Settings in NVIDIA, I encourage this because I noticed sometimes my keepers hand getting a black rectangle around it, basically not turning transparent. Although I played through my skirmish (and will continue to play through campaign and skirmish) and I found there is less crashes. I found that the -32bitdisplay causes the lag and the screen problem, so I removed that and kept everything else I have two shortcuts now, one without end Target, and one with an end Target. I will play in both shortcuts and see which one does more, and which one does less.

Again, hope this helps!

Hapuga
September 26th, 2016, 23:58
-enablebumpmapping



Did you see any changes of lighting on surfaces?

xXDzepniXx
September 28th, 2016, 22:17
Did you see any changes of lighting on surfaces?
Yes, but very minimal it was so minimal I hardly noticed it till I really took a look. Maybe I'm just blind?