PDA

View Full Version : annoying bug of 1.5



nayo
March 25th, 2017, 19:24
i noticed when mouse cursor goes over lord of the land the game crashes...

is there a way to fix that bug ?

nayo
March 27th, 2017, 11:10
btw i tried the gim patch... who says that bug got fixed... but i still crash when my mouse is on the lord of the land...

Metal Gear Rex
March 27th, 2017, 13:51
what level is this occurring?

impboy4
March 27th, 2017, 14:42
what level is this occurring?
I think it's any level that has a lord of the land with a gem attached to him.

Metal Gear Rex
March 27th, 2017, 20:50
I think it's any level that has a lord of the land with a gem attached to him.

I asked because if it's not an official level, it might be a problem with the Lord lacking a name.

nayo
March 28th, 2017, 10:55
tried both a level i made and a modified official level (level 14) where i added a vampire lvl 10 with 4 font of mana nearby a wall to the lord of the land to make an easy test :P

i didnt try an unchanged level

if anyone knows a way to avoid the crash to occur, other than not pointing the mouse cursor on the lord of the land i am eager to listen to :P

in the while i am just finishing a bland gameplay modification, then will try to experiment and find a way over this...

Metal Gear Rex
March 28th, 2017, 14:09
Can you try this with a fresh / unmodified level?

This also may be an issue with the text file. I just remembered a similar bug that would occur when I was doing changes around my patch. I would change certain text IDs related to a creature, but then, long story short, there was some messiness with the text file, causing a crash when hovering over a specific creature because the toolbar is looking for a text ID that doesn't exist in the current text file.

nayo
March 28th, 2017, 14:47
...

nayo
March 28th, 2017, 15:32
wow... i didn't do the tests you asked me yet... but i found something interesting...

somehow the settings in registry i had screw overing mouse cursor on lord of land,

i used an extensiv sfv file checksum on everything, and all was fine... no idea how that bad "magic" happens... then i try to load registry .reg

and puff i get all the problems i had...

now is the time to isolate which entry in registry of bullfrog corrupts the game :D

nayo
March 28th, 2017, 16:38
-----------

now focusing on lord of the land bug...

the bug triggers when your mouse cursor is over the lord of the land, and in the windows registry, inside bullfrog there is this entry: "Level Number"=dword:00000014

i noticed this entry is linked with a specific level... for example if is set to 1 it triggers: antonius, if set to 2 probably sigmund or darius... but the name of the lord of the land changes based on the entry in the file registry.
this is true even for user created map...

so in the end is probably a string problem... when a lord of the land name has to be selected the game picks it based on the entry of the registry.

i am still not sure which file holds the names... i can tell you i have a fully translated game :P so this is why probably this problem happens to me... and maybe not to other people...

nayo
March 28th, 2017, 17:51
...

nayo
March 28th, 2017, 18:39
...

nayo
March 28th, 2017, 19:31
update:

when level 16 is loaded, the entry in the registry is not set to decimal 16, but is set to decimal 20 and so the game crashes when the mouse arrow is put on the lord of the land.

so the bug happens when some levels are loaded in the game, they modify the entry in windows registry but put inside the wrong entry