ok, but how should we call this new "random"?
Maybe "DYNAMIC_RANDOM" or "DRAND"?
Or maybe you have better name?
ok, but how should we call this new "random"?
Maybe "DYNAMIC_RANDOM" or "DRAND"?
Or maybe you have better name?
DYNAMIC_RANDOM seems a little long, but that sounds good. I can't think of any good name, perhaps VARIABLE_RANDOM but RANDOM already is a variable.
Dungeon Keeper 2 Patch: With More Balance and Pie [Hiatus]
Forever Hiatus. Probably. Latest Version: 3.5 w/Levels 1-11 Revised.
The Awakening: GM Powers Activate!
Tesonu is napping!
What about an increase of the portal max after an objective is achieved?
Command:
INCREASE_CREATURES_MAXIMUM(A,B)
A: Player 0 (human),2,3 and 4 (AI), Player good cannot be chosen for obvious reasons.
B: Number of extra creatures the player in question can now attract
For example
Code:REM *** If action point 1 has been reached by player 0 (human) *** REM *** Increase player 0 portal maximum by 5 *** IF_ACTION_POINT(1,PLAYER0) INCREASE_CREATURES_MAXIMUM(PLAYER0,5) ENDIF
In level 3, it uses the MAX_CREATURES command in an IF statement, I believe it works.
Dungeon Keeper 2 Patch: With More Balance and Pie [Hiatus]
Forever Hiatus. Probably. Latest Version: 3.5 w/Levels 1-11 Revised.
The Awakening: GM Powers Activate!
Tesonu is napping!
how about the ability to turn alliance off and on by a simple ",0" and ",1" to the end. (can't remember the CMD )
Is there a command to fake/force the building of a room? Since the AI does it, it can't really be impossible, right? Something like MAKE_ROOM(PLAYER1,BRIDGE,x,y) and also SELL_ROOM?
How about merging: DISPLAY_OBJECTIVE, DISPLAY_INFORMATION, DISPLAY_OBJECTIVE_WITH_POS and DISPLAY_INFORMATION_WITH_POS into one single command?
DISPLAY_MESSAGE([Objective or Information],[Number],[Player to display the message],[Zoom to],[X],[Y])
[Objective or Information] - Either OBJECTIVE or INFORMATION
[Number] - Text ID
[Player to display the message] - Can be PLAYERX or ALL_PLAYERS
[Zoom to] - Can be PLAYERX for a Dungeon Heart, a number for Action Point or Hero Gate, 0 for no zoom and ALL_PLAYERS for following coordinates.
[X] - X coordinate to zoom to (ignored if "Zoom to" isn't ALL_PLAYERS)
[Y] - Y coordinate to zoom to (ignored if "Zoom to" isn't ALL_PLAYERS)
I like dragons! They're the center of my life! I'll never forget them...
Yeah, I also get an urge to bring some order there.
But the old commands will have to be supported anyway, so that would only make redundant command. I will express my need of order when I'll be designing special map format for KeeperFX - it will support dynamic size of maps and have better scripting.
There's no need to give second name for the same thing.