Results 1 to 8 of 8

Thread: Have GOG DKII... which patches would work best?

  
  1. #1

    Default Have GOG DKII... which patches would work best?

    Hi Everyone!

    I've been reading around the forums a bit, and I've gathered that there's a lot of controversy about certain patches, and which one really works or not (and certain tradeoffs with using said patches over the other).

    Long story short, it'd be great if I could get some advice on what would work best for me.

    I have a Win7 64bit on a dual-core PC. I haven't had any problems playing with older games so far, and I'm confident that I can probably make a game work if I jury-rig it enough.

    So my main issue is gameplay and graphics. Crashing after a few minutes is bad, but I don't expect to play a 100% stable old game on a modern PC, so if I can keep it to a single crash every few hours, I'd call it good.

    I once downloaded a DKII Silver Edition, and played it vanilla and greatly enjoyed it on my laptop (Win7 32bit, single core). Now I hear that fanmade version of the game uses the nerfed 1.70—but I was pretty comfortable with it. I saw some posts that said the main bad thing about 1.7 is that the AI didn't attack and defend (but it fixed high-level units not appearing and combat pit issues). If that's the case, then I think I can be happy with 1.70, since I'm a turtler-player at heart, and I like the economy and base-building aspect over the military one.

    I did experience some crashes every 2 hours of gameplay though.

    So I got the DKII from GOG as a gift from a friend, and I believe that it uses the 1.70, and has good support, came cheap (and legal!), and supposedly is meant to work with less problems on my modern system.

    Should I still patch it though?

    Right now, I'm torn between:
    Vanilla GOG (v1.70)
    1.73f (am I correct is assuming that the one that can be downloaded from http://keeperklan.com/downloads.php?do=file&id=15 is the "f" version?)
    1.80 (easily found on other sites)

    NOTE: I never plan to play multiplayer, so that's never an issue for me.

    I was all set to go with 1.73(f), but then I read that there were some issues with the campaign level 1? On that same thread, I found some helpful posts that supposedly would fix the issue, but what's the accepted solution? Or is this no longer an issue with the latest version of 1.73? Is 1.73 such a big upgrade to 1.70 that it's worth the headaches of fixing the campaign map level 1 issue?

    To make the issue even more confusing, there's supposedly a HARDWARE ACCELERATION PATCH from GOG (I can't seem to be able to find it, even on the GOG site). Is this also a necessary patch (and if so, anyone have it?)

    Any words of advice, anyone?


    UPDATE: I've installed the vanilla GOG, and I've got it working with little problems without having to edit anything (like compatibility or affinity). I just had to make sure to turn off hardware acceleration. However, I've been playing pet-dungeons, so I don't know if there are any issues with campaigns. Either way, any advice yet if I should upgrade to 1.73? Thanks!
    Last edited by Justin Abello Éxito; February 8th, 2013 at 09:14.

  2. #2
    Your Majesty Hapuga's Avatar
    Join Date
    Aug 2009
    Location
    Austin, USA
    Posts
    1,444

    Default Re: Have GOG DKII... which patches would work best?

    Ok, let's break down this into versions to eliminate confusion once and for all.

    Here are the existing versions of DK2:

    1.3 (aka the release version, aka 1.0. The one without the version in the main menu and no patch.txt file)
    1.3 cracked (aka cracked by crazy russions)
    1.51 (the original patched version, from 1.3)
    1.6
    1.61
    1.7 (aka the ultimate 1.7, that patches from 1.3-1.7 or 1.51-1.7 or 1.6-61-1.7)
    1.7 GOG edition
    1.7 cracked
    1.7 silver edition
    1.71
    1.72
    1.73
    1.8

    1.0/1.3 is the ultimate original version that runs only with a disc (physical or virtual). Has no level editor, crashes randomly on different levels, has more or less stable MP. This is the pre ME times, so the game was originally designed for Win98. The game runs very well on Windows 2000, and runs pretty well on Windows XP SP2. It has some problems on Windows XP SP3, however most of the time it is still runnable. The game runs well on Windows 7 64/86, because Win7 has a very powerful emulation tool. The main problem starting from WinXP is the graphics card that you use. I was able to make the game run on both Radeon and Nvidia cards, however I had to spend a lot of time tweaking stuff. For my last build (win7 24gb ram 2.7 i7 proc 8 threads, 7 series Radeon 1.5gb) I was able to run DK2 1.0/1.3 string out of the box. Why this version? Because it has a working AI which is pretty good. At least it attacks and defends properly.

    1.3 cracked is a pirated russian edition, that has both a cracked original 1.3 and a russian version with russian fonts and a (horrible, I confirm as a russian) voiceover. This build is pretty stable, I'd say, more stable than the original DK2, plus you don't need to emulate the cd. Some people claim that it does not work, however I think they simply did not put enough effort into making it work. This version worked well for Win XP SP2/3, and for my older laptop with Nvidia Quadro 1600m. It does not run on my new laptop (and I don't care, I run the original). Same AI as above.

    1.51 is an original patched version, somehow underrated and overlooked, probably due to a quick emerge of 1.7 after it. The 1.3-1.51 patch is a pain in the ass to find nowadays. This version gives a massive boost to game AI, and fixes mot of "random" crashes in the game. I requires a cd, physical or virtual. This version pretty much has the same windows/hardware requirements as the original 1.3.

    1.6 this version introduces the elite creatures.... and breaks the AI to the level beyond retarded. AI no longer attacks or defends. It builds a better and bigger kingdom than 1.3/1.5 AI, however dont ever expect it to send armies at you. Sometimes, when the stars align perfectly and its Thursday, it will drop 1 goblin to shoo away your imp that claimed his tile. But that's it. Has relatively similar requirements as the previous version.

    1.7 is the "original" version that most people are used to. It completely destroys the game, by destroying the last more or less workable game aspect - the multiplayer. With the introduction of the 0 player error, 50% of the matches are unable to start, the other 50% crash miserably at random points in time. This game version introduces the mercenaries, the new creature (maiden) and the jack in the box trap, in other words, stuff that you will never ever see or use most probably. The random crashes are mostly gone, and it runs well on Xp and has a 50% to run well on a modern system. A lot of people choose this version simply because this is the only version they know about.

    1.7 GOG edition is a very good patch for 1.7 that eliminates most of the graphical glitches from the game, and making it relatively high-def. It deserves to be called 1.8 realistically, because it is the best 1.7 adaptation to date. Is spread with the GOG download of the game.

    1.7 cracked is the same as the original 1.7, with only exception of running without a cd.

    1.7 a pretty good revamp of the 1.7 version, making it even more runnable on new sytems, less laggy in the main menu (for some people), and has some fixes like level logic and level crashes. Therefore, most people choose it. Gold version was never released, which is very very disappointing (the person was planning to fix the AI). This is the ONLY unofficial 1.7 version that actually has some reverse engineering in it (meaning that the person who did this knew what he was doing). If you are still into 1.7, get this version. Can't blame u.

    1.71 was a fail attempt to make the game more stable.

    1.72 another fail attempt.

    1.73 is a pretty successful attempt, some files were merged, some level fixes were introduced. This version is almost as good as 1.7 silver edition. If SE does not work, try it.

    1.8 was a fake patch that claimed to fix stuff, but failed. The person creating it had no idea what he was doing, and though the effort is appreciated, the output is very poor. This "patch" was simply a copy/paste of other patch versions making a separate "version". In reality it has a base of 1.73, with a few files copied over. While some people claimed that this worked for them, it broke the game for others.

    Now, to review:

    First of all, if you are planning to patch your game, the most logical steps are: 1.3-1.7-1.73, or standalone 1.7 silver edition, or 1.3-1.51-1.7-1.73.
    The following versions are the actual patches:
    1.3-1.51
    1.51-1.6
    1.3-1.6
    1.6-1.61
    1.3-1.7
    1.51-1.7
    1.7-1.7(1,2,3)
    1.7 - cracked 1.7

    Silver edition is not a patch, it is a stand alone. 1.3 cracked is not a patch it is a standalone. 1.7 cracked comes as a patch and as a standalone.

    You cannot patch down a game.
    You cannot apply a patch to a version that is unrelated (1.3-1.73), (1.7 GOG - 1.73).

    So, here is the final review:

    1.3 vanilla - great version.
    1.3 cracked - great version.
    1.51 - the best version of the game.
    1.6 - don't use
    1.61 - don't use.
    1.7 vanilla - what 95% of people use.
    1.7 silver edition an enhanced 1.7 version.
    1.7 GOG a very good adaptation of 1.7 version.
    1.71 - don't use.
    1.72 - don't use.
    1.73 - an okay version to try.
    1.8 - don't use.
    Last edited by Hapuga; February 9th, 2013 at 01:07.
    http://img192.imageshack.us/img192/6659/c2warlocki.gif

  3. #3

    Default Re: Have GOG DKII... which patches would work best?

    Hi Hapuga!

    Thanks for taking the time to give such a great summary. It really helped me decide.

    Just a final quibble though—which would be better, Silver or GOG? Given that both a slightly modified versions of 1.7.

    Again, I never plan to play multiplayer, so most of the issues about 1.7 breaking that part of game don't really upset me that much.

    BTW, right now I'm using the GOG 1.7 version, using their Hardware Acceleration patch/EXE so I've been playing with crisp graphics so far with no need to do any tweaking (GOG already set the compatibilities and such). But I noticed that you seem to favor Silver over GOG. Care to share why? Should I reinstall with Silver instead?

  4. #4
    Your Majesty Hapuga's Avatar
    Join Date
    Aug 2009
    Location
    Austin, USA
    Posts
    1,444

    Default Re: Have GOG DKII... which patches would work best?

    They are both equally bad, if you ask me The AI is dead in all verions past 1.6, meaning all SE, GOG, cracked, vanilla, 1.73 etc will have the same dead AI. The impression that I value SE over GOG is false. While both are good adaptations for newer hardware and OS, they have the 1.7 base which is broken and bad. Try 1.51, you won't regret it. 1.3 and 1.51 are the best versions of DK2 gameplay-wise. Might be a bit harder to make them work on newer systems, but the reward is great (epic Skirmish battles). In case you are ok with the 1.7, go GOG, as it is the most recent update.
    Last edited by Hapuga; February 9th, 2013 at 20:16.
    http://img192.imageshack.us/img192/6659/c2warlocki.gif

  5. #5

    Default Re: Have GOG DKII... which patches would work best?

    Quote Originally Posted by Hapuga View Post
    They are both equally bad, if you ask me The AI is dead in all verions past 1.6, meaning all SE, GOG, cracked, vanilla, 1.73 etc will have the same dead AI. The impression that I value SE over GOG is false. While both are good adaptations for newer hardware and OS, they have the 1.7 base which is broken and bad. Try 1.51, you won't regret it. 1.3 and 1.51 are the best versions of DK2 gameplay-wise. Might be a bit harder to make them work on newer systems, but the reward is great (epic Skirmish battles). In case you are ok with the 1.7, go GOG, as it is the most recent update.
    I might add that the GOG changes can be easily ported to the 1.73 version to create a "best" 1.7-branch version... maybe to be called 1.73GOG ?! http://keeperklan.com/threads/1051-U...ll=1#post39956

    The adresses and changed bytes (comparision between the GOG 1.7 and the timeslip patched GOG 1.7)
    C:\Program Files\GOGcom\Dungeon Keeper 2>fc DKII.EXE DKII-dx.exe
    Comparing files DKII.EXE and DKII-DX.EXE
    0028B8D8: 44 50
    0028B8D9: 44 41
    0028B8DA: 52 54
    0028B8DB: 41 43
    0028B8DC: 57 48

    Basically just changing "ddraw" to "patch" to redirect to the patch.dll by timeslip. And this can be easily added to the 1.73 too. (in fact already added it, see link above)

    Also, do you know if the 1.73 is based on the Silver Edition? Can someone provide the SE exe for comparison?
    Last edited by helsinkiharbour; March 9th, 2013 at 16:33.

  6. #6

    Default Re: Have GOG DKII... which patches would work best?

    Quote Originally Posted by helsinkiharbour View Post
    And this can be easily added to the 1.73 too. (in fact already added it, see link above)
    Is this added? Is it possible for now to patch latest gog version with 1.73 ?

  7. #7

    Default Re: Have GOG DKII... which patches would work best?

    Quote Originally Posted by Hapuga View Post
    1.6 this version introduces the elite creatures.... and breaks the AI to the level beyond retarded. AI no longer attacks or defends. It builds a better and bigger kingdom than 1.3/1.5 AI, however dont ever expect it to send armies at you. Sometimes, when the stars align perfectly and its Thursday, it will drop 1 goblin to shoo away your imp that claimed his tile. But that's it. Has relatively similar requirements as the previous version.
    This is related only to skirmish and multiplayer? If I care only about singleplayer campaign, it will be easier because of broken AI? Or it will be the same as in 1.3 ?

    Quote Originally Posted by Hapuga View Post
    a russian version with russian fonts and a (horrible, I confirm as a russian) voiceover
    If you mean 7-wolf localization, then I like their russian voicover, and even will use it for live streaming in 1.73 GOG (hope 1.73 patch will work with gog version correctly)

    Also there is a chance, that we will make our own Russian voiceover in future

  8. #8

    Default Re: Have GOG DKII... which patches would work best?

    It's broken in the single player campaign as well. Either play 1.3, 1.51 or GIM.

Similar Threads

  1. Dungeon Keeper 2 Patches?
    By Mimas in forum Dungeon Keeper 2
    Replies: 5
    Last Post: December 21st, 2012, 21:14
  2. I just bought DKII
    By Necror in forum General Discussion
    Replies: 15
    Last Post: May 7th, 2012, 18:36
  3. Working on DKII
    By Displacer in forum Dungeon Keeper 2
    Replies: 27
    Last Post: September 15th, 2011, 12:25
  4. Replies: 2
    Last Post: June 18th, 2011, 03:00
  5. so, my DKII won't start...
    By Mortarus in forum DK2 Troubleshooting
    Replies: 6
    Last Post: September 1st, 2010, 19:28

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •