Results 1 to 2 of 2

Thread: Problem with DK2 Black screen

  1. #1

    Default Problem with DK2 Black screen

    Hey guys Drkillzown here.
    First off I have a Dell 15" Inspiron touch with an HD Intel Graphics card.

    Firstly i found my old DG2 game today and was mega excited because I love and loved the game and couldn't wait to play it.
    Put it in, installed it etc etc. Went to go play the background was fine, but when I went start new campaign or any other option, the texture went all black and i only saw the background every now and again and when in game the map was completely black and never saw anything except little bits of the HUD.

    I searched online to fix this, I tried running compatability settings, tried going into the task manager and tried the set affinity, my computer comes up with CPU 0,1,2,3 and 4, i disabled all except for 0, maybe there's a problem because there's 5 instead of 0 and 1? I'm not sure anyway, ive tried running all compat. modes and nothing works.

    Please help, this is a great game and I love it so much, would be a shame to not play it. Any advice would be very very helpful.

    Regards, DrKillzown!

  2. #2

    Default Re: Problem with DK2 Black screen

    Here is what solved the black screen issue for me in Dungeon Keeper 2 (ver 1.51).
    OS: Windows Xp.

    1. Click on the Start Menu in the lower left corner.
    2. Pick "Run..." in the menu.
    3. Type: dxdiag
    4. Pick the "Display" tab at the top.
    5. In the "DirectX Features" area click on "Disable" right next to "DirectDraw Acceleration".

    After that, Dungeon Keeper 2 worked fine for me.

Similar Threads

  1. Partly black screen
    By roland in forum DK2 Troubleshooting
    Replies: 4
    Last Post: October 14th, 2011, 14:58
  2. Black Play-map
    By DSJesterXII in forum DK2 Troubleshooting
    Replies: 12
    Last Post: June 5th, 2011, 13:00

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts