Page 3 of 3 FirstFirst 1 2 3
Results 21 to 29 of 29

Thread: Something surreal is happening...

  1. #21
    Demon Spawn
    Join Date
    Jul 2016
    United Kingdom

    Default Re: Something surreal is happening...

    Quote Originally Posted by YourMaster View Post
    O, in that case I know what's up. It's on maps where neutral units are placed on neutral rooms, for people playing with a recent alpha version of KeeperFX Unofficial. In that alpha the units are then assigned to the neutral rooms in a way that looks cool, but unfortunately causes all kinds of silly stuff like this.

    I want to release a new version of KeeperFX Unofficial soon, I made it already, but I've been putting it off because I'm not in the mood for thoroughly testing it. The new version would basically the latest alpha, with all the changes that don't work that well taken back out again. And this neutral thing is one of those.

    In the meantime, you should be able to easily fix this yourself by adding the text 'PASSIVE_NEUTRALS' to 'PreserveClassicBugs' at line 38 of fxdata\rules.cfg.

    EDIT: I've released an alpha to hold people over. That should not have this bug anymore. Please let me know if this is not the case.
    I've been looking at the code, and the error messages all seem to be traceable back to THINGS_COUNT, which is defined as 2048 in thing_list.h. I'm clutching at straws here, but have you tried increasing THINGS_COUNT? I've just tried this (enabling active neutrals) again in the latest alpha, and it happened again. The log starts (after the level has loaded) with a load of 'Cannot find door for flagged position' errors from get_navigation_colour_for_door (for some reason it seems to be trying to locate a door across the entire map; for there are 500 of them, the first 255 being for coördinates 255, y, with y starting at 0 and going up to 255, and the next 255 being for coördinates x, 255, with x starting at 0 and going up to 255) I then get about a zillion 'Infinite loop detected when sweeping things list' errors (which are thrown if local integer variable k is larger than THINGS_COUNT (that is, 2048)), many of which are from the update_things_in_list function. Even the get_navigation_colour_for_door error seems to involve THINGS_COUNT. I'd hate to see this feature having to be dropped altogether.
    Last edited by AdamP; June 2nd, 2019 at 18:29. Reason: typo

  2. #22

    Default Re: Something surreal is happening...

    Yeah, in the latest alpha I just disabled the function to get rid of the errors. And those limits are unfortunately all there for a reason. Simply increasing the number doesn't work.
    I would love to be able to keep this feature, but I have no idea on how to do so or even where to look.

  3. #23

    Default Re: Something surreal is happening...

    Seems like stuff still happens in the second last mission of the original campaign (Mistle), can't even use 'Possession' spell 'cause it freezes the game.

  4. #24

    Default Re: Something surreal is happening...

    With the latest alpha you mean. If so, do you have a log file for that?

  5. #25

    Default Re: Something surreal is happening...

    KeeperFX Unofficial (Complete)>1850>1896>1901 This is what I have, I've updated to the latest alpha build by overwriting the old one. Maybe I need to do a 'clean install'? Dunno.
    And yes, I have both log file and save files.

    The save file should be the first one, I uploaded them all just in case.

  6. #26

    Default Re: Something surreal is happening...

    I think I know what happened. I believe you started this campaign on version r1896, updated to r1901 midway, and then got to lvl 19. Lvl19 has neutral dragons in prison so suffers from the bug, and the config from r1896 is loaded in the save, so you'll still be affected by the bug.
    What you can do is start the game with the 'level 19' command line parameter, save the game, and continue from that save later on. This way it's updated and you should be ok.

  7. #27

    Default Re: Something surreal is happening...

    Well, I wasn't sure where to put this 'level 19' command so I deleted the whole game folder and everything, reinstalled the game using the GOG version (KeeperFX Unofficial (Complete)>1850>1901, also overwrited the sound.dat with the new one) cheated my way to the level 19 and still have this bug.
    Am I doing something wrong?

  8. #28

    Default Re: Something surreal is happening...

    Using the 'level 19' command line option is just a way to cheat yourself to lvl 19. A reinstall should not have been needed.

    But I have no idea why you are still having issues. I just tried lvl19 with build 1901, confirmed that the neutral dragons are indeed not imprisoned. Possessed an imp without issues. And used frameskip for a while to check the log afterwards and I saw no errors in my log.

    So could you tell me more about the troubles you're having? When do they start, what do you do to get them?

    Also, could you check to confirm that in your keeperfx\fxdata\rules.cfg on line 38 it says 'PreserveClassicBugs = PASSIVE_NEUTRALS'?

    If so, could you send me yet another log from after the crash.
    And after that you could if you don't mind go back to build 1889, which is before this bug was introduced. If that is still giving you issues we can be sure that it is a completely different bug.

  9. #29

    Default Re: Something surreal is happening...

    Ok, when I reinstalled the game the 'PreserveClassicBugs = PASSIVE_NEUTRALS' line wasn't in the .cfg for some reason, I guess I didn't copied the files correctly or something, but the command is there now and the game works as it should.
    Thanks for the help.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts