Page 4 of 5 FirstFirst ... 2 3 4 5 LastLast
Results 31 to 40 of 43

Thread: Korean language support

  1. #31

    Default Re: Korean language support

    Yes, I've tried to build the launcher too, but didn't manage it so far.

    I received some instructions on how to build it from the original developer:
    The launcher is based on wxWidgets:
    You need to set up that library on your system.
    I think the library itself needs to be built.
    The "wx" folder was most likely a symlink to:
    I used the following wxWidgets build config:
    ./configure CXXFLAGS=-ffunction-sections -fdata-sections LDFLAGS=-Wl,--gc-sections --disable-shared --disable-sockets --disable-http --disable-ftp --disable-protocols --disable-sound --disable-tarstream --disable-zipstream --disable-protocol --disable-mediactrl --disable-webview --enable-no_rtti --disable-debug --disable-gif --disable-pcx --disable-tga --disable-iff --disable-svg --without-libpng --without-libtiff
    For all the building instructions - I probably used some kind of on-line tutorial, as I didn't saved the commands anywhere. In general, when building such project, you:
    1. generate 'configure' script with use of autotools (autoconfig?)
    2. run 'configure' script, adjust its options (and dependencies you have installed) until it succeeds
    3. run 'make'.
    Still, never managed to get it to actually build.

    I think including korean in the new version is really easy, as the code is already there for Korean, it's just commented out. As long as it could be build.

  2. #32

    Default Re: Korean language support

    I bilud it.

    All necessary files were included.

    Built in msys 1.0

    Finally, the long journey seems to be over.

    Thank you very much for the support.

  3. #33

    Default Re: Korean language support

    That's great, well done.

    I'm not really a software developer myself, and have not managed to build it. There are however some settings I would like to add, and I would like to see if I could fix the scaling problem. Could you tell me step by step how you managed to build it, so I can give it another go?

  4. #34

    Default Re: Korean language support

    I am working on windows.

    1. set up mingw
    2. add compile component(gcc ... etc) from mingw install manager
    3. add msys(shell and need files) from mingw install manager
    4. run msys shell
    5. download source wxWidgets ( I am using wxWidgets-3.0.5[ ] )
    6. extract drive root\wxWidgets-3.0.5 (If there are spaces or special characters in the path, it fails.)
    7. In msys shell
    7-1 cd /drive root/wxWidgets-3.0.5
    7-2 ./configure CXXFLAGS=-ffunction-sections -fdata-sections LDFLAGS=-Wl,--gc-sections --disable-shared --disable-sockets --disable-http --disable-ftp --disable-protocols --disable-sound --disable-tarstream --disable-zipstream --disable-protocol --disable-mediactrl --disable-webview --enable-no_rtti --disable-debug --disable-gif --disable-pcx --disable-tga --disable-iff --disable-svg --without-libpng --without-libtiff
    7-3 make BUILD=release UNICODE=1 SHARED=0
    8. copy builed file to launchwx folder
    8-1 copy 'lib' folder with static libraries (.a files) and subfolders to 'wx/lib',
    8-2 copy 'include' folder with headers (.h files) and subfolders to 'wx/include',
    8-3 copy file 'build/msw/config.gcc' to 'wx/config.gcc',
    9. In msys shell
    9-1 cd /drive/launcherwx
    9-2 make all

    If you use the uploaded file, you can skip step 7, 8.

    thank you.

  5. #35

    Default Re: Korean language support

    Thank you, I'll give it a go and let you know if it worked.

    Any idea what I did wrong?

    If I do a 'make clean' first, and change '-march=i686' to '-m32' in the build file, it starts to build, but fails here:

    Last edited by YourMaster; June 5th, 2020 at 16:21.

  6. #36

    Default Re: Korean language support

    In msys2, I failed to build for the same reason.

    I am using msys 1.0

    Probably the gcc version is too high.

    msys 1.0 gcc version
    $ gcc -v
    Using built-in specs.
    Target: mingw32
    Configured with: ../src/gcc-6.3.0/configure --build=x86_64-pc-linux-gnu --host=mingw32 --target=mingw32 --with-gmp=/mingw --with-mpfr --with-mpc=/mingw --with-isl=/mingw --prefix=/mingw --disable-win32-registry --with-arch=i586 --with-tune=generic --enable-languages=c,c++,objc,obj-c++,fortran,ada --with-pkgversion=' GCC-6.3.0-1' --enable-static --enable-shared --enable-threads --with-dwarf2 --disable-sjlj-exceptions --enable-version-specific-runtime-libs --with-libiconv-prefix=/mingw --with-libintl-prefix=/mingw --enable-libstdcxx-debug --enable-libgomp --disable-libvtv --enable-nls
    Thread model: win32
    gcc version 6.3.0 ( GCC-6.3.0-1)
    msys 2 gcc version

    $ gcc -v
    Using built-in specs.
    Target: i686-w64-mingw32
    Configured with: ../gcc-10.1.0/configure --prefix=/mingw32 --with-local-prefix=/mingw32/local --build=i686-w64-mingw32 --host=i686-w64-mingw32 --target=i686-w64-mingw32 --with-native-system-header-dir=/mingw32/i686-w64-mingw32/include --libexecdir=/mingw32/lib --enable-bootstrap --with-arch=i686 --with-tune=generic --enable-languages=c,lto,c++,fortran,ada,objc,obj-c++ --enable-shared --enable-static --enable-libatomic --enable-threads=posix --enable-graphite --enable-fully-dynamic-string --enable-libstdcxx-filesystem-ts=yes --enable-libstdcxx-time=yes --disable-libstdcxx-pch --disable-libstdcxx-debug --disable-isl-version-check --enable-lto --enable-libgomp --disable-multilib --enable-checking=release --disable-rpath --disable-win32-registry --disable-nls --disable-werror --disable-symvers --disable-plugin --with-libiconv --with-system-zlib --with-gmp=/mingw32 --with-mpfr=/mingw32 --with-mpc=/mingw32 --with-isl=/mingw32 --with-pkgversion='Rev3, Built by MSYS2 project' --with-bugurl= --with-gnu-as --with-gnu-ld --disable-sjlj-exceptions --with-dwarf2
    Thread model: posix
    Supported LTO compression algorithms: zlib zstd
    gcc version 10.1.0 (Rev3, Built by MSYS2 project)

  7. #37

    Default Re: Korean language support

    I simply compressed my mingw.

    Just unzip it and run "C:\MinGW\msys\1.0\msys.bat"

    I unzipped and build in the VM and confirmed that it worked.

    Thank you.

  8. #38

    Default Re: Korean language support

    I managed to build it, thank you very much!

  9. #39

    Default Re: Korean language support


  10. #40

    Default Re: Korean language support

    0.4.8 release korean play

Similar Threads

  1. a little question in chinese language
    By updata in forum KeeperFX
    Replies: 2
    Last Post: November 12th, 2014, 01:52
  2. Language
    By bluluxabica in forum Dungeon Keeper 1
    Replies: 3
    Last Post: June 18th, 2014, 17:09
  3. Switch language dungeon keeper
    By chrisssj2 in forum DK1 Troubleshooting
    Replies: 3
    Last Post: February 12th, 2010, 14:22

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts