Results 1 to 10 of 10

Thread: Playing on a 21:9 ratio - how can I avoid the game stretching?

  
  1. #1

    Default Playing on a 21:9 ratio - how can I avoid the game stretching?

    Greetings! First post here.
    I tried to play DK with KeeperFX on my 21:9 display (default resolution 3440x1440). On the first launch everything was running perfectly but the game was stretched to fit the ratio so everything was deformed. I tried to change some resolution settings (both in the launcher and in the cfg file) to try to get to the original ratio without stretches, but without any success.
    Now after some changes the game window (even on fullscreen!) seem cut offscreen like here: https://i.imgur.com/J4vVMFB.jpg. Changing the resolution ingame does not fix this, it just changes how it's cut.

    I tried to play in a windowed mode, but the windows is off-centered and if I try to drag it, it instantly moves to the bottom of the screen behind the taskbar and I cannot move the mouse anymore until I close the game with the task manager.

    Here's my configuration:
    -Windows 10
    -Latest GOG release of DK
    -Latest KeeperFX with the alpha build FX_Unofficial-0_4_7_2150_alpha_patch_from_1913
    -Launcher from this thread
    Here's my run options and settings:
    https://i.imgur.com/UdtuhSu.png
    https://i.imgur.com/L9lwx57.png
    Is there any way to play the game in fullscreen but with the original aspect ratio w/ black bars? I don't mind them, they're still better than a stretched image.

    Thanks in advance!
    Last edited by Lavaeolus; August 16th, 2020 at 10:46.

  2. #2

    Default Re: Playing on a 21:9 ratio - how can I avoid the game stretching?

    What's often a problem, is that people with huge resolutions have DPI scaling enabled in windows. Turn that off and KeeperFX will start to work well.

  3. #3

    Default Re: Playing on a 21:9 ratio - how can I avoid the game stretching?

    Quote Originally Posted by YourMaster View Post
    What's often a problem, is that people with huge resolutions have DPI scaling enabled in windows. Turn that off and KeeperFX will start to work well.
    Thanks for your answer! Unfortunately that didn't change anything (both by disabling the DPI scaling from windows and by checking the "remove fullscreen optimization" box from the launcher properties.

  4. #4

    Default Re: Playing on a 21:9 ratio - how can I avoid the game stretching?

    Well, something is scaling your game, and it's not the game itself. You could go to properties when you right click keeperfx.exe, and in compatibility settings go to DPI settings, and for KeeperFX make sure it's at 100%

  5. #5

    Default Re: Playing on a 21:9 ratio - how can I avoid the game stretching?

    Quote Originally Posted by YourMaster View Post
    Well, something is scaling your game, and it's not the game itself. You could go to properties when you right click keeperfx.exe, and in compatibility settings go to DPI settings, and for KeeperFX make sure it's at 100%
    I tried like you said, I even changed windows global scaling to 100% but without any result.

    I had a bit of a hope using the alternative input option thus being able to go windowed mode and moving the window to the center of the screen, but the cursor keeps falling outside of the borders if moving the mouse too much, making it frustrating to play in general and pretty much impossible to use possession.

    Sorry, I know this might be a very specific problem since mine is an uncommon resolution.

  6. #6

    Default Re: Playing on a 21:9 ratio - how can I avoid the game stretching?

    I've had people with high resolution screens with your issue, but also have people that can play it just fine with the very same resolution. So it's related to some kind of settings somewhere, but I wouldn't know which one exactly. I do know your resolution can work just fine for KeeperFX. And that in windowed mode it still doesn't fit is proof of that.

  7. #7

    Default Re: Playing on a 21:9 ratio - how can I avoid the game stretching?

    Quote Originally Posted by YourMaster View Post
    I've had people with high resolution screens with your issue, but also have people that can play it just fine with the very same resolution. So it's related to some kind of settings somewhere, but I wouldn't know which one exactly. I do know your resolution can work just fine for KeeperFX. And that in windowed mode it still doesn't fit is proof of that.
    If it's any help, before installing KeeperFX the game displayed the native ratio and resolution correctly, aka with black bars on the sides.

  8. #8

    Default Re: Playing on a 21:9 ratio - how can I avoid the game stretching?

    That does not help. Think of it this way, if you put the game in a 1024x768w32 (windowed) resolution on your 3440x1440 monitor, and I do the same on my 1920x1080 monitor, why does that work for me and not for you? We both have a window right, of the same size. The only difference would be that you would have more screen left besides the KeeperFX window.
    But instead, I get it working well, and you get screen cut off.

    And others have gotten the widescreen to work just fine:


    But there have also been people who had the same issue as you, and did not find out how to address it. So, what would really help is figuring out why it zooms for you. Somewhere in your graphics control center, or DPI settings, or monitor controls, or something.
    What happens by the way if at your DPI settings you found not to 100%, but to 50%?

  9. #9

    Default Re: Playing on a 21:9 ratio - how can I avoid the game stretching?

    Quote Originally Posted by YourMaster View Post
    That does not help. Think of it this way, if you put the game in a 1024x768w32 (windowed) resolution on your 3440x1440 monitor, and I do the same on my 1920x1080 monitor, why does that work for me and not for you? We both have a window right, of the same size. The only difference would be that you would have more screen left besides the KeeperFX window.
    But instead, I get it working well, and you get screen cut off.
    Windowed mode works pretty much like you said, the only problem, like I mentioned is the mouse falling off the borders.

    What happens by the way if at your DPI settings you found not to 100%, but to 50%?
    I can only increase it in a range from 100% to 500%. My main display is set at 125% by default, but when I put it back at 100% (both on single-display settings and on global windows settings) it didn't solve the problem.

    EDIT
    After changing some launcher setting while on 100% scaling it seems to work as intended! Probably the first time there was some wrong resolution in the settings.

    Two things: is it possible to run KeeperFX without manually setting the DPI scaling at 100% every time I want to play?
    Also, is it possible to make the game zoom out more than what's allowed by default? It's exactly like your screenshot, but with so much space available it feels a bit too close
    Last edited by Lavaeolus; August 17th, 2020 at 09:24.

  10. #10

    Default Re: Playing on a 21:9 ratio - how can I avoid the game stretching?

    Glad you found the correct DPI settings to make it work.
    For windowed mode, try disabling -altinput again if the mouse works against you.

    The latest alpha already fixes a bit of a zooming problem, but no, zooming out further is not possible at the moment. If I disable the zoom-out limit, you can get everything smaller, but you simply get black screen all around. The game can only render x amount of tiles. Straight view can zoom out a bit more.

    And as for the zooming, probably by doing compatibility settings, they are remembered.
    Last edited by YourMaster; August 17th, 2020 at 14:59.

Similar Threads

  1. Anyone still playing?
    By Xay in forum DK2 Multiplayer
    Replies: 6
    Last Post: October 18th, 2018, 19:42
  2. Replies: 2
    Last Post: January 30th, 2013, 16:08
  3. Help playing my map.
    By Powtreeman in forum DK2 Mapmaking
    Replies: 3
    Last Post: April 13th, 2012, 14:11
  4. Recording the game while playing
    By DarK_KaiN in forum DK2 Multiplayer
    Replies: 13
    Last Post: October 30th, 2011, 15:43

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •