Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13

Thread: Updated to latest Alpha 2475

  
  1. #1

    Default Updated to latest Alpha 2475

    I downloaded the latest alpha, and deleted the previous version, but in the new version I can’t find the keeper FX install program ( The one that is used to find the original files so it will work, I think it was called ‘launcher’ or something)

  2. #2
    Spider
    Join Date
    Jul 2016
    Location
    United Kingdom
    Posts
    217

    Default Re: Updated to latest Alpha 2475

    You're not supposed to delete the previous version; you're supposed to install the alpha over it.

  3. #3

    Default Re: Updated to latest Alpha 2475

    well crap

  4. #4

    Default Re: Updated to latest Alpha 2475

    I have 4.8 backed up on a HDD, if I installed that, could I update that to 4.9 Alpha 2475, or would I need a complete edition of 4.9?

  5. #5
    Spider
    Join Date
    Jul 2016
    Location
    United Kingdom
    Posts
    217

    Default Re: Updated to latest Alpha 2475

    Alphas are installed on top of a complete version, so you should be able to install it over 0.4.8.

  6. #6

    Default Re: Updated to latest Alpha 2475

    thanks, in the new alpha the scripts are all together so its hard to edit them, is there an easy fix for this?

    ex
    old version:

    ; KeeperFX Creature Model Configuration file
    ; file version 0.32

    [attributes]
    ; Name is the creature identifier which should be used in level script
    Name = SAMURAI
    NameTextID = 282
    Health = 700
    HealRequirement = 100
    HealThreshold = 100
    Strength = 80
    Armour = 60
    Dexterity = 90
    FearWounded = 12
    FearStronger = 2500
    FearsomeFactor = 125
    Defence = 70
    etc.


    in the new version it's all 4 lines and all together
    (ex

    "; KeeperFX Creature Model Configuration file; file version 0.33[attributes]; Name is the creature identifier which should be used in level scriptName = SAMURAINameTextID = 282Health = 700HealRequirement = 100HealThreshold = 100Strength = 80Armour = 60Dexterity = 90FearWounded = 12
    etc.

    is there a easy way to get it to the old look where each thing is on it's own level instead of all jumbled up

    thanks

  7. #7

    Default Re: Updated to latest Alpha 2475

    Quote Originally Posted by AdamP View Post
    Alphas are installed on top of a complete version, so you should be able to install it over 0.4.8.
    No you can not. This will give you crashes. This is clearly stated in the first post of the Alpha topic. It's needs to go over version 2215 or later. This is due to different SDL files.

    Quote Originally Posted by Junkman1217 View Post
    thanks, in the new alpha the scripts are all together so its hard to edit them, is there an easy fix for this?

    "; KeeperFX Creature Model Configuration file; file version 0.33[attributes]; Name is the creature identifier which should be used in level scriptName = SAMURAINameTextID = 282Health = 700HealRequirement = 100HealThreshold = 100Strength = 80Armour = 60Dexterity = 90FearWounded = 12
    etc.

    is there a easy way to get it to the old look where each thing is on it's own level instead of all jumbled up

    thanks
    I've heard this before, and for that user it fixed itself when he looked again. But for most people, the files look exactly like they did before. What Operating system do you have, and what program do you use to open the .cfg files? I tried with both notepad and notepad++ and they look fine for me.
    Last edited by YourMaster; October 2nd, 2021 at 08:32.

  8. #8
    Mapmaker
    Join Date
    Jan 2012
    Location
    Bristol, United Kingdom, United Kingdom
    Posts
    112

    Default Re: Updated to latest Alpha 2475

    well it was fixed by using a different program. using notepade now it still shows up with it all in one line. I have to open them in wordpad to see them, which I find to be a jankier program to use.

  9. #9

    Default Re: Updated to latest Alpha 2475

    The line endings did change because that worked better with something else. Reading up now, it seems there was a bug in notepad that is fixed in 2018 that would not handle proper line endings. So most likely, going through windows update to see if there's an update to your notepad would work there.
    Also, I can recommend notepad++, it's a much nicer alternative to notepad and also pretty lightweight.
    With an extra bonus of it having the DK script plugin for it, that makes level scripts easier to read and write.

  10. #10

    Default Re: Updated to latest Alpha 2475

    Just tried Notepad++, working fine
    Thanks

Similar Threads

  1. Updated (harder) official campaign
    By drubjak in forum DK2 Maps
    Replies: 20
    Last Post: October 19th, 2014, 20:15
  2. I updated, now DK2 won't start
    By ZaDrugLord in forum DK2 Troubleshooting
    Replies: 3
    Last Post: March 15th, 2010, 01:46

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •